View Issue Details

IDProjectCategoryView StatusLast Update
0000242GTAC Client/GameGrand Theft Auto IIIpublic2021-04-13 17:23
ReporterDeVeX Assigned To 
PrioritynormalSeveritytrivialReproducibilityunable to reproduce
Status newResolutionreopened 
Summary0000242: gta.setCameraLookAt does't work anymore
Description

Since 1.2.13 the target position don't seem to have any effect anymore. The camera stays directed to the north.

TagsNo tags attached.
Game Version

Activities

Vortrex

2021-01-03 20:02

administrator   ~0000130

I was unable to reproduce this problem. Every attempt on all three games works as intended.
Also, you submitted this to the server project, but the gta.setCameraLookAt only exists client-side

DeVeX

2021-01-10 10:16

reporter   ~0000143

So I tried a lot and actually it seems that I cannot interact with player camera unless a player is spawned for the client.
Originally I got the following code, which was working before some update.

The camera is constantly facing north, even though it faced city hall before.

Next try was getting the camera matrix to show some skylines, which lead to see the blue hell...
I tried the matrix in both onResourceStart and onCameraProcess - Same result.

onCameraProcess is getting triggered, I've checked...

Putting setCameraLookAt into onCameraProcess lead to a even stranger result.
Seen in the latest 3 images... while the screenshot from the bridge only appears after reconnecting.

DeVeX

2021-01-10 10:25

reporter   ~0000144

unknown.png (17,999 bytes)   
unknown.png (17,999 bytes)   

Issue History

Date Modified Username Field Change
2020-12-21 23:26 DeVeX New Issue
2020-12-29 01:35 Vortrex Status new => closed
2020-12-29 01:35 Vortrex Resolution open => unable to reproduce
2021-01-03 20:02 Vortrex Status closed => resolved
2021-01-03 20:02 Vortrex Note Added: 0000130
2021-01-10 02:21 Vortrex Status resolved => new
2021-01-10 02:21 Vortrex Resolution unable to reproduce => reopened
2021-01-10 10:16 DeVeX Note Added: 0000143
2021-01-10 10:25 DeVeX Note Added: 0000144
2021-01-10 10:25 DeVeX File Added: unknown.png
2021-02-16 13:51 Vortrex Reproducibility always => unable to reproduce
2021-04-13 17:23 Vortrex Project GTAC Server => GTAC Client/Game