View Issue Details

IDProjectCategoryView StatusLast Update
0000344ServerGrand Theft Auto IVpublic2021-12-09 10:23
Reporterdjebzer Assigned ToVortrex  
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Summary0000344: Sandbox gamemode's default spawn can't be overridden
Description

When running a server on the Sandbox gamemode (30), a default spawn causes functions like 'spawnPlayer' to be useless for example if we want to spawn the player on a specific location, because the default sandbox spawn will teleport the player at the Happiness Island once he loaded everything.

I could add a timer for my custom spawn, but the fact that default spawn differs since it waits for the player to fully load, causes that we can't trust this timer.

The default spawn should be removed since 'spawnPlayer' function can be used instead.

Steps To Reproduce
  1. Set the server to the Sandbox gamemode (30) and join it.
  2. You will spawn in the Happiness Island with all weapons + lots of ammo.
TagsNo tags attached.

Activities

djebzer

2021-08-09 21:03

reporter  

image.png (2,443,956 bytes)

Vortrex

2021-12-09 10:20

administrator   ~0000245

Last edited: 2021-12-09 10:23

View 2 revisions

spawnPlayer will now forcefully respawn the player, destroying the default one at Happiness Island.

Issue History

Date Modified Username Field Change
2021-08-09 21:03 djebzer New Issue
2021-08-09 21:03 djebzer File Added: image.png
2021-12-09 10:20 Vortrex Assigned To => Vortrex
2021-12-09 10:20 Vortrex Status new => resolved
2021-12-09 10:20 Vortrex Resolution open => fixed
2021-12-09 10:20 Vortrex Note Added: 0000245
2021-12-09 10:23 Vortrex Note Edited: 0000245 View Revisions