View Issue Details

IDProjectCategoryView StatusLast Update
0000221ClientGrand Theft Auto IIIpublic2020-12-27 01:53
ReporterDeVeX Assigned ToVortrex  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Summary0000221: getClients() returns only clients with a lower ID
DescriptionWe have been with 3 on the server and checked with a Debug command who sees who client-side. Simple as that... Player 0 sees only hisself, Player 1 sees player 0 and hisself, and Player 2 sees all of them.
Lead to issues with playerboard and some sync features added.
Worked around by getting player entities to fetch the clients from them, but this seems to bug out after some time. (Logs look like the player stopped syncing hisself and returns no more getClientFromPlayer)

Cheers
TagsNo tags attached.
Game Version

Relationships

related to 0000218 resolvedjack9267 Server getClients is sometimes incomplete in client scripts 

Activities

DeVeX

2020-11-29 07:03

reporter   ~0000106

Seems to be fixed since 1.2.5

Issue History

Date Modified Username Field Change
2020-11-21 20:02 DeVeX New Issue
2020-11-21 22:55 Vortrex Relationship added related to 0000218
2020-11-29 07:03 DeVeX Note Added: 0000106
2020-12-27 01:53 Vortrex Assigned To => Vortrex
2020-12-27 01:53 Vortrex Status new => resolved
2020-12-27 01:53 Vortrex Resolution open => fixed